Monday, February 19, 2018

WSJT-X receive levels

By now everyone knows how you should transmit with a clean signal. That means, low power and adjust audio volume to the radio till you get no ALC reading but almost full adjusted output power. A good signal is not that difficult to make, however I had issues with it in first editions of WSJT-X years ago, these days the problems with audio codecs seems to be solved.

I switched over to Windows 10 lately and since a few days I imagined not all signals in the WSJT-X waterfall were decoded. Sometimes even nothing was decoded even if I clearly saw a few traces! Playing with the input volume didn't improve the decoding much. Then suddenly I remembered something I read in the excellent FT8 operating tips guide from ZL2IFB. Of course a lot of those tips are also valuabe for other digimodes like JT65/JT9/PSK and many more.The default bitrate of a soundcard input is always set at 44100Hz CD quality and for digimode it should be 48000Hz DVD quality. And indeed that was my problem. Regarding the input setting there are also some tips in chapter 5 of the FT8 tips guide. It is indeed something everyone should read as receiving is even more important as transmitting. If you cannot hear a signal you cannot work it. 


If you choose the microphone input of your computer as receiving input make shure (if selectable) the extra amplification and all extras are switched off. Tune your radio to a clear frequency with only noise and set the audio to 30dB that should be a basic setting of the input of your soundcard. However it seems there is a difference in soundcards as mine does not get below or above approx 60dB even not when the radio is off or when a strong station is appearing on frequency it stays at 60dB. I wish I could show a picture of 30dB audio but I can't. However it doesn't seem my soundcard is receiving badly? In previous versions of WSJT-X and JTDX there was also a receive input slider, I never understood why the programmers have removed it as it worked very well here. I don't really know why my sound card is behaving like this and still I have a reasonable reception, if anyone has any idea I would like to know.

I know there are many out there that have this problem and did not discover it yet. Please take a look at your waterfall, Count the traces and see if all traces are decoded. Did you miss a few, please take a look at your soundcard settings!


8 comments:

  1. Hallo Bas, ik doe nog een hoop dingen fout met FT8. Bedankt voor de tip, nu heb ik de audio levels ook op 48000 KHz gezet. AGC uit (heb jij dat ook?) en de instellingen wat meer gepluisd. En nu begin ik het toch wel leuk te vinden. Het heeft even geduurd, maar ik moest wel want met alle andere modes wordt het steeds stiller. Ja, dan zie je maar dat ik toch een ouwe zak wordt die iets meer tijd nodig heeft. Met al die andere digi modes was ik toch snel bij. If you can't fight them join them, dus vooruit. Ik ben benieuwd als de Es weer begint op 6 meter met FT8. Dat kan toch leuk worden. 73 Paul PAØK

    ReplyDelete
    Replies
    1. Hallo Paul, het is zeker aan te raden de FT8 tips te lezen. AGC heb ik ook uit. Ik ben ook niet erg dol op FT8 maar het is momenteel wel de mode waar de meeste stations op zitten die interessant zijn om te werken. Mijn voorkeur heeft JT9....73, Bas

      Delete
  2. Hallo Bas. Goed dat jedaar aandacht aan besteed. De ingang krijgt vaak te veel signaal waardoor de decoders niet werken. Ik voer mijn ingangssignaal altijd dusdanig op dat ik alle signalen in de waterval decodeer. Dan heb ik nooit te veel aan signaal en ook niet te weinig. DE methode van 60dB lijkt mij nog nauwkeuriger dus zal ik dat ook gaan toepassen. Tnx, 73 Hans, PE1BVQ

    ReplyDelete
    Replies
    1. Hallo Hans, die 60dB methode? Je bedoeld de 30dB methode denk ik. Bij mij werkt dat in iedergeval niet. Bij mij blijft de meter gewoon op 60dB staan wat ik ook doe. Toen er nog een slider naast stond in eerdere versies van de software kon ik het wel aanpassen. 73, Bas

      Delete
  3. Hi Bas,
    Ik gebruik de USB aansluiting op mijn ICOM 7410. Het signaal is eigenlijk te hard ook al heb ik het audioniveau van mijn Windows Vista microfoon op een minimum staan. Ik heb al wat geprobeerd met Voicemeter maar dan vervormt de audio.
    M.a.w. het is lastig om de audio input te reduceren.
    Mocht jij nog tips hebben dat hoor ik dit graag.

    73 Gerard PA7GMU

    ReplyDelete
    Replies
    1. Hallo Gerard, dan ben ik dus niet de enige met dit probleem. Ik heb zelfs een potmeter op mijn modem zitten om het ingaande geluid te reduceren maar ook al draai ik die helemaal dicht, het maakt allemaal niet uit. Behalve dan dat ik op dat moment ook geen signalen meer zie. Ik heb er op dit moment geen oplossing voor maar misschien iemand anders die dit leest? 73, Bas

      Delete
  4. Hello Bas
    I also found these audio settings critical.
    Running here a SDR-Console / SDRplay on RX for digital here. Seems to do as well or better than my TS590S.
    73 Angel

    ReplyDelete
    Replies
    1. Hello Angel, sometimes these settings can be very critical indeed. But it seems many haven't even noticed they have no decodes. If you use lower as 48000 bit rate you get sample errors. 73, Bas

      Delete

Thanks for your comment. Bedankt voor je reactie. 73, Bas