Friday, 29 August 2014

Maintenance time (Icom IC-706MK2G FM power problem)

Dust collected on the internal fan
Since we moved to our house we live now in 2008 I had some problems with my Icom IC-706MK2G. Not really big problems so I let it go for the time being till there was time, tools and a proper room to repair. It is a known bug of the IC-706. The power on FM is sometimes decreasing and there is some frequency drift when the problem occurs. When the radio has been used for a hour the problem is gone. Another problem that occured last year was a strange beeping sound when listening to CW mode.




I decided it was maintenance time and first of first I blew out all the dust collected in 15 years inside the radio with compressed air. That, of course, can never be wrong! I found the solution for the FM power problem on the internet. Though it is originally a version 1 IC-706 problem which has another print lay-out as the MK2G version I have. So I had to sort things out with the service manual. In the IC-706 there is a problem with solder joints on the VCO trimmer cap signed C267. Of course in the IC-706MK2G it is signed differently but almost on the same location. Searching for the same FM power problem and IC-706MK2G on the internet gave no results. It seems to be no one ever had problems with it. I verified it with the service manual and found that C1022 was the VCO trimmer. This is a so called SMT trimmer and it looks big on the photo, but I can assure you it is small, very small. I've been examining the solder joints on both sides of the cap with a magnifying glass and didn't trust at least one side (right on photo) with less solder on the joint. So after gathering courage I carefully tipped the joints with my soldering iron and some fresh solder. Everything went well and testing the radio the problem seems to be solved now. I checked the frequency to be shure soldering the trimmer didn't alter the alignment. So far it would be a little low on the MFJ259, but it can be that it's counter is not that accurate. On FM no one will notice.

The strange thing is that the CW beeping problem has been solved as well? Has it been dust? I hope the radio will hold for a couple of years again. I've been looking for another HF radio but I guess as long as the Icom does the job it will always be a dream.



Sinds we in 2008 verhuisd zijn naar het huis waar we nu wonen heb ik problemen met mijn Icom IC-706MK2G. Niet echt grote problemen dus heb ik het eerst maar laten zitten tot ik de tijd, ruimte en de spullen had om het te repareren. Het is een bekend probleem met de IC-706. Het vermogen op FM is soms wel en soms niet of heel laag aanwezig, daarnaast staat de set dan een paar Khz onder de frequentie tijdens het probleem. Als de set een uurtje gebruikt word is het probleem over. Een ander probleem dat ik niet kon thuisbrengen is een vreemd gepiep tijdens het luisteren op CW mode, net alsof er een keyer is aangesloten. Een keyer heb ik niet eens en luisteren naar CW doe ik zelden, dus dat was voor mij niet zo een groot probleem.

Ik besloot dat het maar eens onderhoudstijd was en allereerst heb ik met de compressor alle stof maar eens goed uit het binnenste geblazen wat zich verzameld had in 15 jaar tijd. Dat kan natuurlijk nooit verkeerd zijn! Ik vond de oplossing voor het FM vermogen probleem op internet. Origineel is dit een probleem dat voorkomt bij de versie 1 IC-706 met een geheel andere print lay-out als de MK2G versie die ik heb. Dus moest ik even de service manual erbij pakken. In de IC-706 is er een probleem met de solderingen van een VCO trimmer condensator C267. Natuurlijk is de trimmer niet C267 genaamd in de IC-706MK2G maar zit wel bijna op dezelfde plek. Zoeken naar het FM power probleem en IC-706MK2G geeft op internet geen resulaten die je kan gebruiken, blijkbaar heeft niemand er ooit last van gehad. Volgens de service manual was C1022 inderdaad de VCO trimmer die ik zocht. Dit is een SMT trimmer en hij lijkt groot op de foto maar ik kan je verzekeren dat hij heel, heel erg klein is. Ik bekeek de solderingen met een vergrootglas en vertrouwde vooral de rechter soldering niet zo, daar zat minder soldeer op als links. Dus na het verzamelen van een beetje moed toch maar de soldeerbout gepakt en beide pootjes met een beetje nieuwe soldeertin aangestipt. Daarna goed gekeken of er niet nog stukjes tussen de printbanen zaten. Het leek allemaal goed. De radio weer aangesloten en voor zover lijkt het probleem opgelost. Ik heb de frequentie nog even gemeten om te kijken of het solderen van de trimmer niets heeft beïnvloed aan de afstelling. Het lijkt een beetje laag, maar misschien dat de MFJ259 niet zo accuraat is. Op FM zal in iedergeval niemand het opvallen.

Het gekke is dat het CW piep probleem ook opgelost is? Is het stof geweest? Geen idee maar ik hoop dat de radio het weer een paar jaar volhoud. Ik heb wel eens gekeken naar een andere HF radio maar ik vrees dat zolang de Icom het nog doet dit alleen maar een droom blijft.

8 comments:

  1. Hallo Bas, mooi dat je het probleem opgelost hebt. Stof, een groot probleem met elektronica. Computers hetzelfde. Door de fan wordt ook veel stof meegezogen. Dat is met onze zenders net zo. Tja, ik moet ook maar eens blik naar binnen werpen. En het stof verwijderen, zodat ie weer beter kan koelen. 73 Paul

    ReplyDelete
    Replies
    1. Hallo Paul, eigenlijk viel het me nog mee. Vergeleken met de computer zat er maar weinig stof in. Een computer word meestal geen 15 jaar oud, zo ie zo niet als je het stof er nooit uitblaast. Koeling is belangrijk voor electronica. Hoe koeler hoe langer de levensduur. 73, Bas

      Delete
  2. Great job, Bas! When I look under the hood of my truck and under my radio equipment, I realize that someone with a steadier hand and better vision is cut out for any maintenance I need. A great radio for sure.

    ReplyDelete
    Replies
    1. Hello Phil, things (maintenance) are not always easy. I had some luck on my side I think. Hands didn't shake and I used magnifying glasses. The Icom is holding on. Sometimes wish for a more modern radio. But actually can't complain...73, Bas

      Delete
  3. Hallo Bas, complimenten dat je de klacht vakkundig opgelost hebt. Slechte soldeerverbindingen komen erg vaak voor, dat weet ik nog wel uit mijn vroegere job. Een slechte soldeerverbinding komt vaak pas jaren later aan het licht.
    Door vervorming en warmte openbaart dit zich na jaren. Zeker als de klacht temperatuur gevoelig is dan is het in de meeste gevallen een breuk in een printspoor of een slechte soldering. Fijn dat de klachten weer zijn opgelost dan kun je weer genieten van je set. En zo oud is hij toch nog niet dat vervanging noodzakelijk is? 73 Hans, PE1BVQ.

    ReplyDelete
    Replies
    1. Hallo Hans, nou ja vakkundig. Heb het resultaat maar niet gefotografeerd :-). Zo netjes zag het er nou ook weer niet uit, maar de soldeerverbindingen waren in ieder geval goed. Alvast weer een beetje soldeeroefening voor komende projecten. 73, Bas

      Delete
  4. Good evening Bas, it sure does take some guts to venture into the SMT world!! I agree that taking the iron to ones rig sure does require a stiff drink and some "here we go and let see what happens" Great pics and nice to read that all went well. I can remember either adding or removing some SMT parts to my K3 to enhance the rig. The first few time I added an SMT part to my K3 it was far from a work of a work of art but it worked so I left it.
    Mike

    ReplyDelete
    Replies
    1. Hello Mike, this was the first time I ever soldered a SMT part. I hope I never have to do it again. It's far too small for me. I'm happy everything worked again after the work. Learned from faults in the past and checked twice if no solder was left around between parts. 73, Bas

      Delete

Thanks for your comment. Bedankt voor je reactie. 73, Bas